IMAP with SSL connection issue

rybosom
Posts: 5
Joined: Mon Jul 17, 2017 8:10 am

IMAP with SSL connection issue

Postby rybosom » Mon Jul 17, 2017 8:19 am

After chahnging DNS records for mail server to launch WebMail service on mail server IMAP SSL secured connections stopped working - Outlook throws an error: 0x800CCC0E.
I am using Mail Enable Enterprise 9.74 on Win Server 2012 R2.
Funny thing is that insecure connections on port 143 are working. Webmail works on https using the same certificate that was used for IMAP 993/995. SMTP service is working on port 587 using the same certificate.
Any help appreciated.

MailEnable-Ian
Site Admin
Posts: 8510
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: IMAP with SSL connection issue

Postby MailEnable-Ian » Tue Jul 18, 2017 12:52 am

Hi,

Enable the IMAP debug logging within the IMAP properties window. Once enabled restart the service and then analyze the debug log file. Look for when the service started and if there are errors binding to the SSL certificate.
Regards,

Ian Margarone
MailEnable Support

rybosom
Posts: 5
Joined: Mon Jul 17, 2017 8:10 am

Re: IMAP with SSL connection issue

Postby rybosom » Tue Jul 18, 2017 7:26 am

Hi Ian,
Thanks for reply. Here's what I found in Log:

ME-F0084: Unable to bind alternate port to IP Address ((All)), Port (993), Family (2). Error (10048). Could not start service. Check that another service is not running or security software has not prevented access to the port.


As I generally understand what this error means, can you point me where to look in MailEnable management console to check whether all settings are correct?

MailEnable-Ian
Site Admin
Posts: 8510
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: IMAP with SSL connection issue

Postby MailEnable-Ian » Wed Jul 19, 2017 1:41 am

Hi,

The IMAP service is not able to bind to port 993 as there is another service using the port. I'm not sure which one but you can verify this by performing a netstat test within a Windows command prompt. I.e:

netstat -a -b > C:\log.txt

The above command will pipe the results out to a text file. Open the file and search for 993 to see which other service is bound to that port.

You can always change the IMAP port to another port within the IMAP properties window:
http://www.mailenable.com/documentation/9.0/Enterprise/IMAP_General.html
Regards,

Ian Margarone
MailEnable Support

rybosom
Posts: 5
Joined: Mon Jul 17, 2017 8:10 am

Re: IMAP with SSL connection issue

Postby rybosom » Wed Jul 19, 2017 12:34 pm

here's what I got:

Search ":993" (2 hits in 1 file)
C:\log.txt (2 hits)
Line 22: TCP 0.0.0.0:993 SRVWAWMAIL01:0 LISTENING
Line 222: TCP 192.168.1.189:993 srvwawmail01:45660 ESTABLISHED

MailEnable-Ian
Site Admin
Posts: 8510
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: IMAP with SSL connection issue

Postby MailEnable-Ian » Fri Jul 21, 2017 1:41 am

Hi,

Ok, it seems you have another process binding to 993 (SRVWAWMAIL). You will need to change the IMAP alternative SSL port to something else (change to 995 maybe) or change/stop the process from binding to port 993
Regards,

Ian Margarone
MailEnable Support

rybosom
Posts: 5
Joined: Mon Jul 17, 2017 8:10 am

Re: IMAP with SSL connection issue

Postby rybosom » Fri Jul 21, 2017 2:17 pm

Ian, thanks for support. It was indeed another process using port 993, in this case POP3 of MailEnable. Maybe you should think of developing a warning for admin if two different services are set to use the same port.

trice001
Posts: 1
Joined: Wed Aug 23, 2017 5:57 am

Re: IMAP with SSL connection issue

Postby trice001 » Wed Aug 23, 2017 5:58 am

thanks

Who is online

Users browsing this forum: No registered users and 12 guests