MTA Pickup Event Debugging

nathand
Posts: 105
Joined: Wed Aug 20, 2003 4:34 am
Location: Richardson, TX

MTA Pickup Event Debugging

Postby nathand » Mon Mar 23, 2015 3:31 pm

I moved from Windows 2008 to Windows 2012, and I've been unable to get the pickup event working again.

My command looks like this:
c:\strawberry\perl\bin\perl.exe C:\xxxx\script\mail\mailenable\mta_pickup.pl

It runs fine from the command line.

The debug log shows that it runs:
03/23/15 10:09:30 MTADeliverMessage::Pre Pickup Event executing: c:\strawberry\perl\bin\perl.exe C:\xxxx\script\mail\mailenable\mta_pickup.pl 7176E4F70ADE4BD0A9CC94792AAD6F6A.MAI SMTP
03/23/15 10:09:32 ME-MTA-INFO : Routing message (7176E4F70ADE4BD0A9CC94792AAD6F6A.MAI) from (SMTP) to 1 recipient(s).

But, there is no evidence that it actually works. Is there a way to capture the output of the mta pickup event to see if there is an error being generated?
Any other debugging suggestions?
Thanks.

MailEnable-Ian
Site Admin
Posts: 8296
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: MTA Pickup Event Debugging

Postby MailEnable-Ian » Tue Mar 24, 2015 2:52 am

Hi,

Try and enable high level debug logging for the MTA agent to see if there is more clues:

http://www.mailenable.com/kb/content/article.asp?ID=me020585

Anything in the Windows event log?
Regards,

Ian Margarone
MailEnable Support

nathand
Posts: 105
Joined: Wed Aug 20, 2003 4:34 am
Location: Richardson, TX

Re: MTA Pickup Event Debugging

Postby nathand » Wed Apr 01, 2015 8:20 pm

I'm not seeing anything in the Event Log that looks even remotely related.

The MTA Debug log adds a few things, but they don't look like they shed any light on the problem. Here is a sample:
[4356] Processing file 487050D49D7544328095E6CE28EE6DE3.MAI from queue SMTP
04/01/15 00:00:59 [4356] MTADeliverMessage::UnLockCommandMessage: Message 487050D49D7544328095E6CE28EE6DE3.MAI in queue SMTP exclusive lock was released with a status of Delivering
04/01/15 00:00:59 [4356] MTADeliverMessage:: Checking status was Delivering for 487050D49D7544328095E6CE28EE6DE3.MAI
04/01/15 00:00:59 [4356] MTADeliverMessage::Pre Pickup Event executing: c:\strawberry\perl\bin\perl.exe C:\xxxx\script\mail\mailenable\mta_pickup.pl 487050D49D7544328095E6CE28EE6DE3.MAI SMTP
04/01/15 00:00:59 [4356] MTADeliverMessage::Pre pickup event (process 5964, thread 4396) was executed for message 487050D49D7544328095E6CE28EE6DE3.MAI in queue SMTP.

nathand
Posts: 105
Joined: Wed Aug 20, 2003 4:34 am
Location: Richardson, TX

Re: MTA Pickup Event Debugging

Postby nathand » Wed Apr 01, 2015 8:33 pm

Is there any way I can dump the output of my script somewhere when the MTA triggers it?

nathand
Posts: 105
Joined: Wed Aug 20, 2003 4:34 am
Location: Richardson, TX

Re: MTA Pickup Event Debugging

Postby nathand » Sun Apr 05, 2015 1:26 am

Stopping the MTA and running it from the command line with debug turned on showed me that the Perl script was failing because it couldn't find a required lib when run from the MTA.

c:\>memta -debug

Who is online

Users browsing this forum: No registered users and 1 guest