SMTP configured DNS servers are not used

Polderdijk
Posts: 4
Joined: Fri Apr 10, 2009 3:32 pm

SMTP configured DNS servers are not used

Postby Polderdijk » Wed Aug 02, 2017 7:44 am

My setup:

Multi-nic (LAN/WAN)
Some split-DNS domain names (hosted internaly with internal IP's and hosted externaly with public IP's)
Multiple public IP4 and IP6

MailEnable setup:
SMTP > General > DNS server addresses: 8.8.8.8 & 8.8.4.4
SMTP > Inbound > Binding: one Public IP4 and one Public IP6
SMTP > Outbound > Binding: select one Public IP4 (why i can't select multiple IP's from diferent NIC and IP6?)

Problem:
If MailEnable need to send mail to one of the split DNS domain names it resolves to the (internal) IP resolved from the internal hosted nameserver from a nameserver configured on the LAN-NIC (not resolved via the 8.8.8.8 or 8.8.4.4 nameservers so I got a external IP).
Because outbound binding is set to a fixed public IP from the WAN-NIC MailEnable can't contact the internal mailserver via LAN-NIC.

Dirty solutions:
- Set Outbound IP to (default). But the side effect is mail will retouted out via a wrong WAN-IP so mail is tagged as SPAM due to misconfigured Reverse DNS etc.
- Edit host-file (currect situation). Not nice if i change IP-adresses I need to remember to change the host-file.

Best solution:
- How can I forse MailEnable to use the configured nameservers in de SMTP-General Tab?
- Can I (via Regedit) change the settings so i can configure for each NIC a specific outbound IP? So I can set for the WAN a single IP4 and IP6 address and for the LAN a single local IP4 address.

Polderdijk
Posts: 4
Joined: Fri Apr 10, 2009 3:32 pm

Re: SMTP configured DNS servers are not used

Postby Polderdijk » Fri Sep 01, 2017 3:09 pm

Any body an idea?

Who is online

Users browsing this forum: Bing [Bot] and 11 guests