SPAM Rules / Webmail Settings Not Working

nmnadmin
Posts: 6
Joined: Fri Mar 17, 2017 10:07 am

SPAM Rules / Webmail Settings Not Working

Postby nmnadmin » Tue Jun 20, 2017 5:39 pm

I upgraded to 9.74 a few weeks ago and I am seeing a new behavior whereby the spam rules set in the webmail are completely ignored and all spam is automatically delivered to the Junk E-mail folder.

I have tried to reset the settings by changing their values and turning spam rules on, then off, The result is still the same all mail marked as spam is sent to the Junk E-mail folder, regardless of the settings in the webmail spam rules.

Any help is appreciated, as I have two clients who want to handle the spam rules on their end, to capture/see false positives.

MailEnable-Ian
Site Admin
Posts: 8406
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: SPAM Rules / Webmail Settings Not Working

Postby MailEnable-Ian » Wed Jun 21, 2017 12:19 am

Hi,

Please review the following: http://www.mailenable.com/kb/content/article.asp?ID=ME020529
Regards,

Ian Margarone
MailEnable Support

nmnadmin
Posts: 6
Joined: Fri Mar 17, 2017 10:07 am

Re: SPAM Rules / Webmail Settings Not Working

Postby nmnadmin » Wed Jun 21, 2017 2:21 am

I have reviewed the URL and figured it out. Here is what I did: I removed the "Mark as Spam" filter action and replaced it with a "Add Header" filter action, that adds the "X-ME-Spam: High" header. This way the so marked spam is allowed to follow the path selected by the user in the webmail settings' "Spam Rules":

However, I think the documentation needs some clarification: It would be very helpful to point out here that "Mark as Spam" in effect disables the Spam Rules in the webmail for any SA marked spam and to illustrate the above mentioned alternative.

I am also not sure that the process as it is is the best alternative. It is confusing to both users and administrators looking at the settings in the webmail, as to why selected options do not apply to some or all of their spam. It might be a better idea to either let the user setting for HIGH (Spam Rules) override the "Deliver-To=Junk" header or note in the appropriate sections that the latter will force deliver tu the junk email folder overriding user selection in the Spam Rules.

Either way, thanks for your help Ian.

Who is online

Users browsing this forum: No registered users and 3 guests