[SOLVED] Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Wilsonm
Posts: 5
Joined: Thu Sep 14, 2017 8:44 am

[SOLVED] Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Postby Wilsonm » Thu Sep 14, 2017 9:57 am

Hi,

Emails which are sent via outlook or any smartphone are not there in the sent items folder of webmail. The emails are delivered. When I checked the server for the C:\Program Files (x86)\Mail Enable\Postoffices\domain name.org\MAILROOT\Username\Sent Items folder. There are emails which are only sent via webmail. What troubleshooting do I need to do in order to get the send emails to save in the Sent Items folder. I am using Mailenable version 7.5 and it is configured on windows server 2012 R2

MailEnable-Ian
Site Admin
Posts: 8439
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Postby MailEnable-Ian » Tue Sep 19, 2017 2:31 am

Hi,

The first step is to download and update the Standard free edition your running to the latest as 7.5 is outdated. There has been extensive work to IMAP and other MailEnable core services since 7.5 that you need to address. After the update to 9.76 Standard try your tests again and report back.
Regards,

Ian Margarone
MailEnable Support

Wilsonm
Posts: 5
Joined: Thu Sep 14, 2017 8:44 am

Re: Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Postby Wilsonm » Wed Sep 20, 2017 4:24 am

Hi ,

I have upgraded the Mailenable to version 9.76 standard and the problem still persists.

Regards,

Wilson

smccarthy945
Posts: 41
Joined: Thu Oct 16, 2014 8:04 pm

Re: Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Postby smccarthy945 » Thu Sep 21, 2017 11:24 am

I am having the same issue. When I use Thunderbird with IMAP, it works. When I go back to Outlook with the Mailenable connector, no luck.

MailEnable-Ian
Site Admin
Posts: 8439
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Postby MailEnable-Ian » Mon Sep 25, 2017 1:02 am

Hi,

I am having the same issue. When I use Thunderbird with IMAP, it works. When I go back to Outlook with the Mailenable connector, no luck.


Which MailEnable Connector are you referring to? If the MailEnable MAPI connector it does not work with Standard edition. The MailEnable MAPI Connector only works in Enterprise and Enterprise Premium editions.

I have upgraded the Mailenable to version 9.76 standard and the problem still persists.


Ok, can you inspect the IMAP activity log file and check to see if the message you are sending is being appended to the "Sent items" folder. You should see similar lines like below when the message is copied to sent items:

Code: Select all

09/22/17 10:12:23   IMAP-IN      2548   192.168.2.18   SELECT   SELECT "Sent Items"   * FLAGS (\Deleted \Seen \Answered \Flagged \Draft $Forwarded)   261   24   mailenable.com.au   test
09/22/17 10:12:24   IMAP-IN   5DC1EBAA55C9440BBCBFA631F504AEB5.MAI   2548   192.168.2.18   APPEND   APPEND "Sent Items" (\SEEN) {1039}      63   1080   mailenable.com.au   test


Also what smart phone are you referring to?
Regards,

Ian Margarone
MailEnable Support

Wilsonm
Posts: 5
Joined: Thu Sep 14, 2017 8:44 am

Re: Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Postby Wilsonm » Mon Sep 25, 2017 6:49 am

Hi Ian,

The folder : "C:\Program Files (x86)\Mail Enable\Logging\IMAP" has an IMAP-Activity-150917 log file and it is empty.

I am using an Android Smart phone.

But even when I configure the email on my laptop using outlook 2016. The problem remains the same.

Unable to connect to the mail enable server using IMAP. So I have configured the settings on outlook also using pop.

Regards,

Wilson Machado

smccarthy945
Posts: 41
Joined: Thu Oct 16, 2014 8:04 pm

Re: Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Postby smccarthy945 » Mon Sep 25, 2017 11:05 pm

Wilson and all involved, I found the issue with the help of someone from Mailenable support. I was having the same issue with SENT items disapearing on me in Outlook. The issue was that the firewall was blocking some of the Mailenable SMTP commands. Since the commands they use are non-standard, the firewall will drop them if it doesn't recognize them. I let the SMTP port through and told the firewall not to scan any SMTP commands and the SENT items are now working perfectly.

Just program your firewall not to examine the SMTP commands or bypass on port 25 and the problem will be fixed. This problem haunted me for many months and forced me to use Thunderbird with DAV for a long time. As a suggestion to Mailenable, you might want to build in a firewall check or some way to check to make sure firewalls are not blocking the command set as it's pretty common for firewalls to scan SMTP to protect the network.

Scott

smccarthy945
Posts: 41
Joined: Thu Oct 16, 2014 8:04 pm

Re: Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Postby smccarthy945 » Tue Sep 26, 2017 7:28 pm

Bad news. I thought opening the port on the firewall was the solution but today I went into SENT items and just watched all the email I sent today disappear. It was sitting in the SENT ITEMS and as soon as I clicked to look for an email in SENT items, boom - sync takes place and all the email I sent today GONE.

My Outlook crashes 3-4 times a day as well so I don't know if it's related. I turned on troubleshooting mode and am going to post the logs once it happens again. I need to get this fixed. It's going to really hurt me one day.

smccarthy945
Posts: 41
Joined: Thu Oct 16, 2014 8:04 pm

Re: Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Postby smccarthy945 » Tue Sep 26, 2017 10:29 pm

This is what I see in the logs with troubleshooting enabled:

2017-09-26 15:27:16.751 ME-EXXXX: (12188) [_HrGetOneProp] _HrGetOneProp return with MAPI_W_ERRORS_RETURNED
2017-09-26 15:27:16.751 ME-IXXXX: (12188) [SynchroniseFolder] Event Driven Synchronisation Request for: Sent Items.
2017-09-26 15:27:16.751 ME-EXXXX: (12188) [_HrGetOneProp] _HrGetOneProp return with S_OK
2017-09-26 15:27:16.846 ME-EXXXX: (12188) [_HrGetOneProp] _HrGetOneProp return with MAPI_W_ERRORS_RETURNED
2017-09-26 15:27:16.846 ME-IXXXX: (12188) [SynchroniseFolder] Event Driven Synchronisation Request for: Sent Items.
2017-09-26 15:27:16.847 ME-EXXXX: (12188) [_HrGetOneProp] _HrGetOneProp return with S_OK
2017-09-26 15:27:16.875 ME-EXXXX: (12188) [_HrGetOneProp] _HrGetOneProp return with MAPI_W_ERRORS_RETURNED
2017-09-26 15:27:16.875 ME-EXXXX: (12188) [_HrGetOneProp] _HrGetOneProp return with MAPI_W_ERRORS_RETURNED
2017-09-26 15:27:16.876 ME-IXXXX: (12188) [SynchroniseFolder] Event Driven Synchronisation Request for: Sent Items.
2017-09-26 15:27:16.963 ME-EXXXX: (12188) [_HrGetOneProp] _HrGetOneProp return with MAPI_W_ERRORS_RETURNED
2017-09-26 15:27:16.963 ME-IXXXX: (12188) [SynchroniseFolder] Event Driven Synchronisation Request for: Sent Items.

MailEnable-Ian
Site Admin
Posts: 8439
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Postby MailEnable-Ian » Wed Sep 27, 2017 1:21 am

Hi,

Hi Ian,

The folder : "C:\Program Files (x86)\Mail Enable\Logging\IMAP" has an IMAP-Activity-150917 log file and it is empty.

I am using an Android Smart phone.

But even when I configure the email on my laptop using outlook 2016. The problem remains the same.

Unable to connect to the mail enable server using IMAP. So I have configured the settings on outlook also using pop.

Regards,

Wilson Machado


POP does not support folder subscriptions and the ability to save sent messages to sent items folder like IMAP. Therefore would explain why you don't see messages appended to Sent Items. You need to configure your devices to connect via IMAP. If you are unable to connect via IMAP then you will need to troubleshoot why. The first step is to determine if you can telnet to the IMAP port via a client machine. Open a Windows command prompt and type: telnet exampledomain.com 143. If you can establish a connection then most likely have a firewall blocking inbound requests on port 143 on the MailEnable server.

Bad news. I thought opening the port on the firewall was the solution but today I went into SENT items and just watched all the email I sent today disappear. It was sitting in the SENT ITEMS and as soon as I clicked to look for an email in SENT items, boom - sync takes place and all the email I sent today GONE.

My Outlook crashes 3-4 times a day as well so I don't know if it's related. I turned on troubleshooting mode and am going to post the logs once it happens again. I need to get this fixed. It's going to really hurt me one day.


Hi,

Troubleshooting mode is only used by the developers and therefore you need to disable it as it will just cause more problems. You only need to set the log files to "Full Detail".

For the messages that have disappeared are they present on the server if you access the mailbox via web mail? Are you sure that the MESAVETOSENT is working after adding your firewall exceptions? Your best way forward would be to configure the SMTP service to listen on an alternative non standard SMTP port like 2525 or something and then configure MAPI to connect to that port for SMTP.
Regards,

Ian Margarone
MailEnable Support

Wilsonm
Posts: 5
Joined: Thu Sep 14, 2017 8:44 am

Re: Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Postby Wilsonm » Wed Sep 27, 2017 4:31 am

Hi Ian,

When trying the telnet command. I get the following error.

telnet webmail.domain.org 143
Connecting To webmail.domain.org...Could not open connection to the host, on port 143: Connect failed

But when I try telnet webmail.domain.org 25
I am able to connect to the server.

Could this be a port 143 blocked on firewall or a configuration on Mail enable which I have to fix it.

Regards,

Wilson

Wilsonm
Posts: 5
Joined: Thu Sep 14, 2017 8:44 am

Re: Emails sent via Smart phone and Outlook client are not seen in the sent items of webmail

Postby Wilsonm » Tue Oct 03, 2017 5:57 am

Hi Ian,

When our security person opened the IMAP port no 143. The sent messages were saved in the folder. I was able to see the sent messages in the sent items of webmail.

Thanks for your help.

Regards,

Wilson Machado

Who is online

Users browsing this forum: No registered users and 5 guests