SSL Renewal Issues

mackilvane
Posts: 4
Joined: Wed Jul 15, 2015 11:27 pm

SSL Renewal Issues

Postby mackilvane » Wed Nov 18, 2015 11:11 pm

I went to upgrade my SSL certificate for our mail server (Win 2008) running Mailenable Enterprise edition, 9.0. It has been nothing but problems.

Followed all the installation steps. Installed the certificate, made sure the IME_SYSTEM users has rights. The certificate shows up in the SSL tab in Mailenable, yet it will not bind to the services, even though the debug log says it does. When I attempt to connect using a Thunderbird client, it uses the webmail SSL that is NOT selected within the SSL tab in Mailenable. The common name is similar, but different, and they worked just fine together before.

I'm seeing entries like this in the POP debug log. Not sure if it's related.

Couldn't decrypt, error 80090327
Couldn't decrypt, error 80090330

I've reissued the certificate countless times and reinstalled, but no change. I'm beginning to despise Mailenable. :evil:

MailEnable-Ian
Site Admin
Posts: 8257
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: SSL Renewal Issues

Postby MailEnable-Ian » Thu Nov 19, 2015 12:03 am

Hi,

Did you remove the old SSL certificate? If the old SSL certificate is still present in the certificate store and is named the same as the new one the services may still be binding to the old certificate.
Regards,

Ian Margarone
MailEnable Support

mackilvane
Posts: 4
Joined: Wed Jul 15, 2015 11:27 pm

Re: SSL Renewal Issues

Postby mackilvane » Fri May 20, 2016 5:54 pm

I did remove the old SSL certificate, but it still would not recognize the new.

I ended up removing them all and using a new wildcard SSL. That fixed the issue.

Who is online

Users browsing this forum: No registered users and 1 guest