Active sync failed over the weekend

jglazer
Posts: 197
Joined: Thu Mar 17, 2005 5:48 pm

Active sync failed over the weekend

Postby jglazer » Tue Jul 05, 2016 1:00 pm

It was working fine until all of a sudden, it no longer works. Nobody was changing anything.

When I enter the following in my browser:

https://mydomain.com/Microsoft-Server-ActiveSync/

I get:
Server Application Unavailable

The web application you are attempting to access on this web server is currently unavailable. Please hit the "Refresh" button in your web browser to retry your request.

Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.

But nothing shows in the event log.


If I go to the same URL without ssl (using http://mydomain.com/Microsoft-Server-ActiveSync/)

I do get an error in the event log and it shows .net 2.0. I don't know if this is correct and I don't know where to change it to .net 4. The application shows .net 4.0 as the framework in the configuration. Any ideas how to correct this? Maybe the above is not related?

jglazer
Posts: 197
Joined: Thu Mar 17, 2005 5:48 pm

Re: Active sync failed over the weekend

Postby jglazer » Tue Jul 05, 2016 9:41 pm

I changed the application pool from

MailEnableEASPool

to

ASP.NET 4.0

And it started working ... for about 5 hours. Back to the error now. What is going on?

jglazer
Posts: 197
Joined: Thu Mar 17, 2005 5:48 pm

Re: Active sync failed over the weekend

Postby jglazer » Wed Jul 06, 2016 3:58 pm

Ok, I've concluded that I have to reboot the server every 8 hours or so to get active sync working again. This cannot be normal behavior. Any suggestions?

MailEnable-Ian
Site Admin
Posts: 8392
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Active sync failed over the weekend

Postby MailEnable-Ian » Mon Jul 18, 2016 3:14 am

Hi,

MailEnable ActiveSync needs to run under the MailEnableEASPool otherwise it fail intermittently like you are seeing. If you were seeing .NET 2.0 Framework errors in the Windows event log prior to making the changes then do this:

1. Revert back to using the MailEanbleEASPool.
2. Open IIS and navigate to the "Application Pools".
3. Locate the MailEnableEASPool and double click it.
4. Set the Framework to 4.0.
5. Next open Windows notepad (run as administrator) and open file and navigate to: Mail Enable\BIN\NetProtocols
6. Open the web.config file and change the lines were it points to the 2.0 Framework paths to the 4.0 Framework paths. See example below:

Code: Select all

      <add name="WebServicesHandler64" path="/WebServices/*.asmx" verb="GET,POST" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll" resourceType="Unspecified" preCondition="classicMode,bitness64" />
      <add name="WebServicesHandler32" path="/WebServices/*.asmx" verb="GET,POST" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" resourceType="Unspecified" preCondition="classicMode,bitness32" />
      <add name="MEIISHandler64" path="*" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll" resourceType="Unspecified" preCondition="classicMode,bitness64" />
      <add name="MEIISHandler32" path="*" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" resourceType="Unspecified" preCondition="classicMode,bitness32" />


to:

Code: Select all

<add name="WebServicesHandler64" path="/WebServices/*.asmx" verb="GET,POST" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" preCondition="classicMode,bitness64" />
      <add name="WebServicesHandler32" path="/WebServices/*.asmx" verb="GET,POST" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" preCondition="classicMode,bitness32" />
      <add name="MEIISHandler64" path="*" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" preCondition="classicMode,bitness64" />
      <add name="MEIISHandler32" path="*" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" preCondition="classicMode,bitness32" />


7. Save the file
8. Restart IIS and check to see if EAS is working and monitor the service for the same behavior.
Regards,

Ian Margarone
MailEnable Support

jglazer
Posts: 197
Joined: Thu Mar 17, 2005 5:48 pm

Re: Active sync failed over the weekend

Postby jglazer » Mon Jul 18, 2016 12:38 pm

I realize it "should" run under that pool but it kept getting that .net 2.0 error. I went to the .net 4 pool just to try and now it seems to be stable. I don't know what might have changed. Perhaps that pool is corrupted somehow. I was tempted to rebuild the pool definition but for now it seems ok. I am a .net programmer so I understand this stuff fairly well. At this point, its working. Odd.

MailEnable-Ian
Site Admin
Posts: 8392
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Active sync failed over the weekend

Postby MailEnable-Ian » Mon Jul 18, 2016 11:21 pm

Hi,

Its not the application pool. Its your 2.0 Framework that is problematic. Have you been installing Windows updates and all service packs for the framework?
Regards,

Ian Margarone
MailEnable Support

jglazer
Posts: 197
Joined: Thu Mar 17, 2005 5:48 pm

Re: Active sync failed over the weekend

Postby jglazer » Mon Jul 18, 2016 11:23 pm

Yes all updates. The application says 4.0 in the settings. I don't know where things messed up.

Who is online

Users browsing this forum: No registered users and 2 guests