MAPI Connector is slow

sagelike
Posts: 243
Joined: Fri Feb 23, 2007 4:58 am

MAPI Connector is slow

Postby sagelike » Thu Oct 13, 2016 4:18 pm

Hi there,

I had to switch client from activesync because Outlook 2013 crashed again as did mine (latest ME on Windows 2008) and it downloads quickly but deleting or moving emails to different folder is painfully slow. I'm using Port 993 with SSL enabling.

Any thought on how to improve performance? Seems odd that this working quickly with standard IMAP or activesync but not the MAPI connector.

It's also unfortunate Contacts integration isn't a little tighter and default address book can't be set.

thx
G

MailEnable-Ian
Site Admin
Posts: 8389
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: MAPI Connector is slow

Postby MailEnable-Ian » Fri Oct 14, 2016 2:42 am

Hi,

Disable all Outlook com addins and only leave the MAPI connector enabled and try again. What version of the connector are you running?
Regards,

Ian Margarone
MailEnable Support

sagelike
Posts: 243
Joined: Fri Feb 23, 2007 4:58 am

Re: MAPI Connector is slow

Postby sagelike » Mon Oct 17, 2016 3:38 pm

I only have evernote COM addin and it was already disabled. I'm using MAPI Connector V2.6.

I also noticed that Outlook isn't synching properly either. I deleted a bunch of emails on my phone - activesync - and they still appeared in Outlook.

thx
Glenn

scree74
Posts: 12
Joined: Fri Aug 22, 2014 10:16 am

Re: MAPI Connector is slow

Postby scree74 » Sun Nov 06, 2016 12:14 am

Hiya Guys

We are also having speed issues with MAPI Connector for Microsoft Outlook have you had any joy at all improving the performance

We use MAPI connector Version 2.60 and Enterprise Premium V9.50

Many thanks in advance
Scott

sagelike
Posts: 243
Joined: Fri Feb 23, 2007 4:58 am

Re: MAPI Connector is slow

Postby sagelike » Tue Nov 22, 2016 3:58 pm

I opened up MAPI ports 137-139 it is definitely faster now. Still not as fast as activesync but much better.

I know that ME has said that MAPI ports aren't needed but it definitely makes a difference so something is going on.

sagelike
Posts: 243
Joined: Fri Feb 23, 2007 4:58 am

Re: MAPI Connector is slow

Postby sagelike » Tue Jan 10, 2017 8:52 pm

It's back to slow and has been for awhile even with ports 137-9 open.

Here's the issues I have with it:

[list=]
[*] Downloading email which hasn't been downloaded or with attachment is very slow
[*] Deleting mail is painfully slow and often throws an error
[*] sometimes email doesn't sync without restart
[*] Not sure how it can be so much slower than activesync.
[/list]

Some shortcomings that should be corrected:

- Contacts handling is a problem. It doesn't seem to know which contact group to use.
- Ability to select how much email to sync would be nice.

Who is online

Users browsing this forum: No registered users and 1 guest