Connector Version 2 and OpenProtocols

MailEnable
Site Admin
Posts: 4433
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Connector Version 2 and OpenProtocols

Postby MailEnable » Tue Dec 23, 2014 11:21 am

MailEnable has some significant announcements to make in relation to its Outlook Connectivity.
Firstly, for those who use MailEnable’s Connector for Microsoft Outlook – Version 2 will be released in the early new year. It has been significantly updated with some significant improvements and bug fixes (improvements specifically for newer versions of Outlook and responsiveness when operating in header-download mode).

Secondly, many MailEnable customers use other vendors in their platform mix. A new connector has been developed using Open Protocols to communicate with other messaging platforms (using protocols like CalDAV, CardDAV, IMAP and SMTP). The connector is provided free for personal use and is available for download from http://www.arpdev.com. This is great news for those hosting e-mail for personal users, or those with customers that use a mix of mail systems. This connector is stable and had been released as public beta. It will coexist with MailEnable's Connector (ie: can be installed on the same system).
Regards, Andrew

kather
Posts: 65
Joined: Tue Jul 03, 2007 6:20 am

Re: Connector Version 2 and OpenProtocols

Postby kather » Thu Jan 29, 2015 9:52 am

Hi Andrew,

downloading and installing the open protocols connector gives me in Outlook 2013 the SERVER tab but not the Open Protocols Server when I'm trying to add a new account. In your announcement it's stated that both connecters can exist on the same system. Also in the user PDF found on the arpdev.com site they say that when adding a new account you must choose the "Open Protocols Servers". I can see only the MailEnable Server.

Am I missing something?

with regards
Walther

MailEnable
Site Admin
Posts: 4433
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Re: Connector Version 2 and OpenProtocols

Postby MailEnable » Fri Jan 30, 2015 6:08 am

Hi Walter, thanks - When you install the connector (http://www.arpdev.com/download.aspx) then it will edit your MAPISVC.INF file and add details in to allow the configuration of a new Outlook service.
The OpenProtocols connector used to be available as a 32 bit and 64 bit installer, but has been changed to work as a single installer (for simplicity).
It might be worth using that installer to make sure that that the connector is installed for the correct bitness.

If you still have problems with the installation and do not see it as a new service provider, then it would be great if you could post the contents of your MAPISVC.INF file (or email it to beta@mailenable.com). It should be under your Program Files/Common Files directory. What version/bitness of Outlook are you using?
Regards, Andrew

kather
Posts: 65
Joined: Tue Jul 03, 2007 6:20 am

Re: Connector Version 2 and OpenProtocols

Postby kather » Fri Jan 30, 2015 9:16 am

Hi,

I found the file under \Windows\SysWOW64 and in the file are several tags regarding the 'openprotocols':

Code: Select all

[Services]
MEOpenProtocols=OpenProtocols Server (DAV,IMAP,SMTP)
[MEOpenProtocols]
Providers=OpenProtocols_MS,OpenProtocols_XP
PR_DISPLAY_NAME=OpenProtocols Server
PR_SERVICE_DLL_NAME=MailEnableMS.DLL
PR_SERVICE_ENTRY_NAME=ServiceEntry_Open
PR_SERVICE_SUPPORT_FILES=MailEnableMS.DLL
PR_SERVICE_DELETE_FILES=MailEnableMS.DLL
PR_RESOURCE_FLAGS=SERVICE_PRIMARY_IDENTITY
[OpenProtocols_MS]
PR_SERVICE_INSTALL_ID={F7374E37-2513-4735-B1C7-50C1DCD96372}
PR_PROVIDER_DLL_NAME=MailEnableMS.DLL
PR_RESOURCE_TYPE=MAPI_STORE_PROVIDER
PR_RESOURCE_FLAGS=STATUS_DEFAULT_STORE
PR_PROVIDER_DISPLAY=OpenProtocols Message Store Provider
PR_DISPLAY_NAME=OpenProtocols Message Store
PR_SERVICE_ENTRY_NAME=ServiceEntry_Open
[OpenProtocols_XP]
PR_SERVICE_INSTALL_ID={F7374E37-2513-4735-B1C7-50C1DCD96372}
PR_RESOURCE_TYPE=MAPI_TRANSPORT_PROVIDER
PR_PROVIDER_DLL_NAME=MailEnableMS.DLL
PR_RESOURCE_FLAGS=STATUS_PRIMARY_IDENTITY
PR_DISPLAY_NAME=OpenProtocols Transport
PR_PROVIDER_DISPLAY=OpenProtocols Transport Provider
PR_SERVICE_ENTRY_NAME=ServiceEntry_Open
[OpenProtocols_AB]
PR_SERVICE_INSTALL_ID={F7374E37-2513-4735-B1C7-50C1DCD96372}
PR_RESOURCE_TYPE=MAPI_AB_PROVIDER
PR_PROVIDER_DLL_NAME=MailEnableMS.DLL
PR_DISPLAY_NAME=OpenProtocols Address Book Provider
PR_PROVIDER_DISPLAY=OpenProtocols Address Book Provider
PR_SERVICE_ENTRY_NAME=ServiceEntry_Open



It Windows 8, Outlook 2013 64" version

Hope to hear from you
regards
Walther

DWS
Posts: 3
Joined: Wed Feb 24, 2016 4:56 pm

Re: Connector Version 2 and OpenProtocols

Postby DWS » Wed Feb 24, 2016 5:09 pm

I try the new "Openprotocol Connector" (because the MAPI Connector doesn't save different SMTP parameters of the original server --and it works--) .. I had already installed "MAPI Connector" on Outlook .. At this time ...after uninstall "Openprotocol Connector" in MAPI Connector i see the logo of "Openprotocol Connector" in "MAPI Connector" and the countdown of Openprotocol Demo Licence !

I try to uninstall and reinstall "MAPI Connector" .. but nothing has changed

What can I do ?

Who is online

Users browsing this forum: No registered users and 2 guests