Mobile Webmail, error loading the Reply page

rgomez
Posts: 22
Joined: Wed Mar 23, 2011 12:30 am

Mobile Webmail, error loading the Reply page

Postby rgomez » Wed Dec 12, 2012 5:31 pm

Hi there,

I'm using MailEnable Professional 7 beta 2.

When I try the mobile webmail, and I try the Reply, Reply All or Forward buttons, after loading an email, I get an "Error Loading Page" message in the center, and nothing happens. The Delete button works fine.

Thanks.

Rodrigo Gómez

rgomez
Posts: 22
Joined: Wed Mar 23, 2011 12:30 am

Re: Mobile Webmail, error loading the Reply page

Postby rgomez » Fri Dec 14, 2012 3:07 pm

With the latest beta, beta 3, the mobile webmail doesn't even allow me to enter. It gives a .NET runtime error page.

MailEnable
Site Admin
Posts: 4434
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Re: Mobile Webmail, error loading the Reply page

Postby MailEnable » Sat Dec 15, 2012 12:03 am

Is there anything in the event log?
Maybe try accessing mobile webmail on the browser on the server itself. It should give a .NET stack trace if there is an error. If you could post that trace here, it will help diagnose the issue. Thanks.
Regards, Andrew

rgomez
Posts: 22
Joined: Wed Mar 23, 2011 12:30 am

Re: Mobile Webmail, error loading the Reply page

Postby rgomez » Sat Dec 15, 2012 4:42 pm

Hello,

Sure, here is the message as displayed in the webserver:

Method not found: 'Void MailEnable.Clients.Web.Page.ForgetCredentials()'.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.MissingMethodException: Method not found: 'Void MailEnable.Clients.Web.Page.ForgetCredentials()'.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[MissingMethodException: Method not found: 'Void MailEnable.Clients.Web.Page.ForgetCredentials()'.]
MailEnable.Clients.WebMail.Mobile.Login.PageLoadHandler(Object sender, EventArgs e) +0
System.EventHandler.Invoke(Object sender, EventArgs e) +0
System.Web.UI.Control.OnLoad(EventArgs e) +99
System.Web.UI.Control.LoadRecursive() +50
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627

Regards,

Rodrigo Gómez

rgomez
Posts: 22
Joined: Wed Mar 23, 2011 12:30 am

Re: Mobile Webmail, error loading the Reply page

Postby rgomez » Fri Dec 21, 2012 2:35 pm

With the latest beta from today (beta 4) this still happens in my installation.

MailEnable
Site Admin
Posts: 4434
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Re: Mobile Webmail, error loading the Reply page

Postby MailEnable » Wed Jan 02, 2013 5:48 am

I could not reproduce the problem (I used current releases).

The problem is most likely an old DLL or assembly form an earlier beta that has not been overwritten (perhaps its readonly or something).

I would suggest removing any files under the following locations:

1. [Program Files]\Mail Enable\bin\NETWebMail\bin
and
2. [Program Files]\Mail Enable\bin\NETWebMail\Mobile

and then running the installer again.
Regards, Andrew

rgomez
Posts: 22
Joined: Wed Mar 23, 2011 12:30 am

Re: Mobile Webmail, error loading the Reply page

Postby rgomez » Mon Jan 07, 2013 3:32 pm

Hello Andrew,

Following your steps I see now that the problems was in fact caused by some of the previous betas: I installed first, when it came out, the only version available, the Premium one, or something like that. Down the line I changed to the Professional one (that's the one I have license for) and the Mobile WebMail is not available there. When reinstalling the folder didn't even got created (although the login screen still has links to the Mobile site, which I think it shouldnt'?).

The only other problem I have now is: in the webmail the encoding seems to be wrong. I see accents and so on incorrectly displayed, but the encoding of the messages is ok: In other clients (OSX Mail, iOS Mail, Postbox in Windows) the characters are ok. Any idea what could be wrong? This started some betas ago, before I didn't had any issue with that.

Thanks for your help.

Rodrigo

MailEnable
Site Admin
Posts: 4434
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Re: Mobile Webmail, error loading the Reply page

Postby MailEnable » Fri Jan 11, 2013 4:13 am

Hi Rodrigo, perhaps you could use webmail to download the source of the MAI and then forward it as an attachment to beta@mailenable.com - then we can inspect the message and behaviour. Thanks.

Also, the webmail link is probably there too from an old beta setting. There may be a setting under the following branch that is enabling it:
HKEY_LOCAL_MACHINE\SOFTWARE[\Wow6432Node]\Mail Enable\Mail Enable\Services\WEBMAIL\Options

Mobile Webmail Association Mode appears to be the key. I suggest deleting it or ensuring its set to zero.
Regards, Andrew

bruce741
Posts: 1
Joined: Tue Dec 17, 2013 8:38 am

Re: Mobile Webmail, error loading the Reply page

Postby bruce741 » Tue Dec 17, 2013 8:55 am

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
ASaleather-jackets [url=http://www.leather-jackets.me]leatherjackets[/url]
learnspanishonline [url=http://www.learnspanishonline.ws]spanish[/url]
it training courses [url=http://www.test-king.com]it training courses[/url]
312-50v8 exam [url=http://www.actualtests.com/exam-312-50v8.htm]312-50v8 exam[/url]

pondshus2
Posts: 5
Joined: Wed Oct 30, 2013 7:26 am

Re: Mobile Webmail, error loading the Reply page

Postby pondshus2 » Mon Dec 23, 2013 11:09 am

You are lucky to even have logged in. I get a framework error, giving me some numbers and things like that. I am just fed up with the mobile app. I would rather get up with my PC for this.









-------------------------------------
CORBIN GRAVELY

Who is online

Users browsing this forum: No registered users and 1 guest